In the original Profile User Interface this is obvious:

  • Go to the desired Profile
  • Find the section called ‘Standard Record Type Settings’
  • Look for the label ‘Content Versions’
  • Click [Edit] and select the desired default value.

However in the Enhanced User Interface I can't locate this same option.


You could disable "Enable Enhanced Profile User Interface" under Customize > User Interface to restore access to the ContentVersion Record Type Settings on Profiles and then set the Record Type Default as needed. There's no penalty for switching between the Enhanced and the "Unenhanced" Profile User Interface, so it's a harmless change to achieve the desired results.

  • Unfortunately I don't have the permission to do that - this is a client environment. So far @AlwaysThinkin your suggestion is the only way I've found that this can be done, but I'd like to find a way that doesn't' require this switching back and forth between interface types. Jun 9 '15 at 23:07
  • Go to the desired Profile
  • Find the section called 'Object Settings'
  • Choose your desired Object and Click [Edit]
  • select the desired default value.

Hope it helps ...

  • 1
    That's what I thought too Yuval, but I found that (unlike the original Profile User Interface) Content Version does not appear as an Object. Apr 15 '15 at 15:24

How to change profile content record type assignment


  • Welcome to SF.SE John. Its preferred that you provide details from the link giving credit to the author, particularly should the link ever disappear. If you will, please update your answer with more information. Link only answers eventually wind up in a queue where they're voted on for deletion.
    – crmprogdev
    Jun 29 '15 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.