2

Under Administration Setup - Security Controls - Single Sign-On Settings, I need to turn off Federated Single Sign-On Using SAML. However, whenever I disable the SAML Enabled checkbox and click [Save], I get the following error:

Error: Your organization or community is currently using SAML as an authentication method, so you can’t disable it.

Under Domain Management - My Domain, I've changed the Authentication Service setting to Login Page. Yet I keep getting the above error. How do I completely disable SAML for this Sandbox?

8
  • 1
    Do you have a community or portal?
    – CyberJus
    Apr 10, 2015 at 20:13
  • I'm not sure I understand the question, but this is in a Sandbox environment. Apr 13, 2015 at 13:09
  • Do you have a community or portal activated? Those can use the SAML settings as well, so you would not be able to turn it off if you are still using them.
    – CyberJus
    Apr 13, 2015 at 17:13
  • I'm pretty much a newbie when it comes to SFDC. How would I know if I have a community or a portal activated? Apr 13, 2015 at 17:31
  • In the setup menu Customize>Communities >All Communities for Communities and Customize>Customer Portal or Customize>Parter Portal for portal.
    – CyberJus
    Apr 13, 2015 at 20:28

2 Answers 2

4

If you are unable to delete SAML Single Sign-On Settings in Salesforce, check the below before deleting it.

  1. Go to Domain Management --> My Domain. Check whether the SAML Settings is disabled in "Authentication Configuration" section. If not, please disable it.

  2. Please check the Portal Login and Registration Settings and Community Login and Registration Settings and do the same.

1

this is a known issue with no fix: https://success.salesforce.com/issues_view?id=a1p30000000sY1bAAE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.