2

In a process I'm building, I'm trying to evaluate if a particular lookup field is changed and proceed to the "action" if so. Simple enough, right?

It appears that there isn't any way to do that sort of field evaluation on a lookup field. Process Builder forces me to drill to the related object. For example, if I want to evaluate the Account.CSM/RM custom lookup field, Process Builder forces me to select Account.CSM/RM.UserId instead. This doesn't accomplish what I'm looking for - I need to evaluate the field on the account, not on the user record.

Am I missing something obvious?

I have some ideas for workaround that involve creating a new text field and workflow rule/field update in addition to the process, but I'd like to avoid that if possible.

Thanks!

3

You should be able to do this. I just did a test in my dev org and it worked fine. For Owner ID, there are two choices, the field itself (no arrow), or the related object (with an arrow). Make sure that you are choosing the Owner ID field itself, and not drilling into the Owner object. See below

enter image description here

Then you have your conidtion that checks that the ownerID field (on the account) has changed

enter image description here

EDIT:

Here is a look at a custom lookup field to the user object. I still get two options

enter image description here

  • Thanks Ninja. I chose a poor example in an attempt to post a relatable question. My actual use case is a custom lookup field called "CSM/RM" on the account. It doesn't appear that this works with custom lookup fields. I've edited my original post to make the question more clear. – Charles Naughton Apr 9 '15 at 16:46
  • Hmmmm. I can't seem to replicate. I have a custom lookup on account called 'Premium Plus TAM', it's just a custom lookup field to the user object. It sounds like its similar to your use case. I get both options the Id field itself, and the option to drill into it. I added it to my answer. Are you not getting the two options? – Chris Duncombe Apr 9 '15 at 16:51
  • Thank you Ninja - your screenshots were extremely helpful. Notice that the label is used in the drill down, while the API name is used for the actual field. I was searching using the label (which was changed and doesn't match the api name), which is why I wasn't seeing it. I really appreciate the help. – Charles Naughton Apr 9 '15 at 16:57
  • No Problem. Glad you got it working. – Chris Duncombe Apr 9 '15 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.