0

Using the HaoIDE add-on for SublimeText 3 I'm having an issue when I attempt to "Run Test Class" from the context menu, it seems to be greyed out and when I use the hot key (Ctrl+Alt+T) I see an error message at the bottom that says "Component is not active"

I the correct project active and the class I have open is in fact a @isTest class that is already deployed to the environment.

0

There is likely an issue with the session of your project to environment. Try some of the following options (preferably in this order):

  • Restart Sublime Text (there may be an update that needs to happen from HaoIDE)
  • HaoIDE > Cache > Clear Session Cache (this should end your session so you can refresh it)
  • HaoIDE > Switch Project (This should re-attempt to login to the projects SF environment with a new session)
  • HaoIDE > Update Project (This should re-sync your project)

NOTE: File vs Project Context/Relationship

Also keep in mind that all context menu options from HaoIDE are related to the project and file relationship. So for example, if I have Production AND Sandbox packages locally that I'm working in, and I have a production file open but I'm in the sandbox project, then there is no relationship and the typical options like "Run Test Class" will not be available

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.