2

I have a formula field which , when I'm pulling to page layout is not showing up at all. i.e the field itself is not showing up ,let alone value.

Also , when I'm querying the field in a controller , it's saying : No such column 'ABCD__c' on entity 'PAC__c'.

Please suggest.

4

looks like your Field Level Security (FLS) has not been setup correctly. Even though you made your field available on a page layout, the FLS must be enabled for your profile to be able to see the field on the page layout and on a query.

So have a look at the field again, click on button 'Set Field Level Security', enable it for your profile and you should be good to go!

| improve this answer | |
  • 1
    That solved it . Should have thought about it in first place ! – Vanilla_Sky Mar 27 '15 at 7:03
1

Do you have permission to access that field. Go to create --> object --> Pac --> Select your field. Then Set Field-Level Security and make sure it is visible to your profile. Thanks

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.