7

I'm trying to post data into an DX using the Fuel API, specifically as described here. This worked for a prior DX, but I was asked to change to a different one, where I'm receiving a rather unhelpful error message.

Headers

{'Content-Length': u'133', 'accept-language': 'en-us', 'Accept-Encoding':
'gzip, deflate, compress', 'accept': '*/*', 'User-Agent':
'python-requests/1.2.3 CPython/2.7.6 Darwin/14.0.0', 'content-type':
'application/json', 'Authorization': 'Bearer bearer-token-goes-here'}  

Body

[
  {
    "keys": {
      "email": "john.doe@test.com"
    },
    "values": {
      "lastName": "Doe",
      "IP_Address": "127.0.0.1",
      "firstName": "John"
    }
  }
]  

Response (400/Bad Request)

{
  "message": "Unable to save rows for data extension ID
dx-id-goes-here",
  "errorcode": 10006,
  "documentation": ""
}  

An error code of 10006 is unfortunately missing from their documentation, and there is no further message in the body. I accept that the issue may be in what I'm sending or my DX configuration, but I'm able to update it with the same data manually via Marketing Cloud UI, and at any rate am given really nowhere to look next.

  • Where do you define business unit while creating an app? – Maneesh Nov 19 '15 at 2:54
  • 1
    In my case the problem was because of wrong data type. – Łukasz Mar 17 '16 at 16:33
6

After speaking with support, the error was due to the API key I have not having rights to the context/business unit where the Data Extension lived (I didn't set it up and from what I can tell the business unit can't be seen/edited once created). I created a new API client app in App Center with the correct business unit and this resolves the issue!

2

Updated link to error docs in their Marketing Cloud API (ExactTarget was renamed to Marketing Cloud when Salesforce made the acquisition)

The code now exists in their docs. It means 'there are other errors in the response' that you can check. I'm not always seeing other errors to in the response as it claims. But, when there are other errors, it is reporting (in my case) that I have a data type issue with one of my variables.

  • I've seen this when trying to use a string value for a Boolean typed field. – Adam Spriggs Jun 27 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.