2

In Spring '15 Process Builder is supposedly available via the IDE. We are trying to deploy to another developer org so using IDE. It says it deploys successfully and we see it in destination org but when we try to open it get the dreaded "Error" with the cryptic codes "285468849-52567 (-18248785)"

Our Process Builder calls Flows and I ensured Flow was active before moving it, but still get error. Should we be able to do this successfully?

Also cross posted in "Official: Salesforce Workflow Automation" Community Group

  • You may wish to change "Depoly" to "Deploy" for better search results. I'd do it myself, but non authors aren't allowed to make show changes – Jagular Mar 9 '15 at 15:24
2

In your package.xml is API version 30.0 or 31.0, or do you set manually the version to 33.0 ? If the version is before 33.0 in the package.xml, as Process Builder is a new tool appeared in version 33.0, the XML file generated in the flow directory will be incomplete.

| improve this answer | |
  • I think you might be onto something here as the version is 31.0 so this would make sense. But I see on Force.com IDE latest version is Summer '14. I have latest version. Can I just manually change the version in the package.xml and expect that to work? – ddeve Mar 30 '15 at 19:28
  • Ok so I see I cannot just change it. So essentially there is no way to use API 33.0 using Eclipse IDE right now given there is no update to the IDE? – ddeve Mar 30 '15 at 19:59
  • So the answer for now is No you cannot deploy via the IDE since you cannot use API v 33.0 using that. But using another method such as MavensMate via Sublime Text where you can set the latest API it works. – ddeve Mar 31 '15 at 1:56
  • You can change manually the version to 33.0 in the package.xml file of your Eclipse project and it should works (I have succeeded to deploy this way a simple flow on the Opportunity standard object). The Process Builder Flow will be inactive after deployment and you have to activate it manually. – Mael Monnier Apr 1 '15 at 7:50
  • Manually changing API in Eclipse didn't seem to work for me. It doesn't recognize Process Builder flows, at least it didn't for me or I did something incorrectly. MavensMate and Sublime are working fine for the most part. – ddeve Apr 1 '15 at 12:10
1

You mentioned that "I ensured Flow was active before moving it".

But did you activated it in the destination org ? Flow deployment standard behavior is to deploy the flow with an "Inactive"status.

Have you tried to capture a log via the developper console too ?

| improve this answer | |
  • Yes to the activation comments, no on the log and will try that. I think the API version might be the issue. I showed the issue to the Salesforce developer at a Lightning week meeting and she was perplexed and seemed to think it should work so I'll see if deploying by some other method where can use current API yields better results. – ddeve Mar 30 '15 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.