2

I noticed an issue regarding updating field API names and the use in Flows.

Any changes in API names are automatically 'refactored' in flow. i.e., assignments, use in decision elements and screens is updated as expected. Nothing wrong, great!

But when referencing the field at runtime (when running the interview) the field seems unaccessible, the flow returns an error like this:

UPSERT --- UPSERT FAILED ---  ERRORS :  (INVALID_FIELD_FOR_INSERT_UPDATE) Case: bad field names on insert/update call: *field api name* ---  for SFDC record with ID : null

The first time this happened I spend considerable time trying to figure out how this is possible, only to find out that after 15 - 60 minutes the problem solved itself.

Does anyone know whether this is a known problem? Right now everytime I update a field API name working in Flow, I take a long coffee break.

2
  • 2
    As a best practice I would always recommend against renaming API name...ever.
    – pchittum
    Mar 4, 2015 at 14:36
  • You are absolutely 100% right. However, these fields are rarely used as mergefields in code, and because we have a high number of flows running in the org, it is more preferable to rename instead of making new fields and replace them all. Mar 4, 2015 at 16:22

1 Answer 1

0

I just ran into this problem.

To immediately solve the problem all I did was save the flow as a new version and activate it and that did the trick.

1
  • Saving as a new version or even as a new flow didn't work for me. I had to completely delete the flow and recreate it. This solved it for me. Thankfully it was a simple flow.
    – Navigatrix
    May 25, 2023 at 17:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .