0

I have a pretty complex formula field for prioritizing leads. After much tweaking and testing, it's working well and calculates effectively for all relevant leads. However, on some leads it shows "#Error!" when shown in a Lead list view, even though it is calculating correctly on the same Lead's detail page.

I've attached two screenshots as examples. In the first you can see that the Lead has a Priority Score of 44 that has calculated just fine.

In the second you can see that the same lead, in the List View shows the Priority Score as an error.

Why would this happen?

Detail View

List View

4
  • Is that the same lead? The name in the list view does not match the name in the detail page. Perhaps you have a duplicate and the dup has an error in the list view and the detail page. Just a thought. – Berg Feb 25 '15 at 16:28
  • Yes it is the same lead. In the list view it displays the name as Last, First and on the detail page as First Last. – OBerm Feb 25 '15 at 16:55
  • here is a way to debug this: 1) break your formula into several custom formula fields that eventually assemble into the final formula field. 2) Change your list view to display the constituent formula fields as columns. 3) This decomposition should help you find the issue – cropredy Feb 25 '15 at 21:19
  • This is difficult to answer without seeing the formula, could you please post it? – Alex S Jun 13 '15 at 10:03
0

Check those records which are throwing error, it might be because the fields used in formula is blank or it is exciding its size

2
  • The formula does not throw an error on the lead's detail page, so I know it is working. For some reason it displays #Error! only when viewed in List View. – OBerm Feb 25 '15 at 16:54
  • As we know that a formula field is dynamic, and the condition provided to create the list view may also effect. Check this values in all open lead view if it is giving the same error. – Maruf Bagwan Feb 26 '15 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.