4

I have a custom object (Volunteer Application) where I'm trying to use custom builder to create a related record (Volunteer Shift). I can create the Shift record, however when I try and populate the ID of the application in a lookup on the Volunteer record it won't work.

I went further to populate the same ID in a text field (external ID) and it worked but I noticed that it's the 18 digit ID, is that a problem? I was thinking of using a field update to trim and update the lookup but that can't be done with a field update. What am I missing??

process builder screencap

  • The only diff between an 18 digit ID and a 15 digit ID is case sensitivity. The latter is case sensitive while the former is not. Your problem would seem to lay elsewhere. – crmprogdev Feb 22 '15 at 17:01
  • Thanks for the feedback. I was thinking a lookup should be fine. I tried to validate what was being passed by passing it to a generic text field (External ID) and it correctly passed the ID. Any thoughts as to how this could be debugged? – Shaun Feb 23 '15 at 1:56
  • I see I originally commented on this a year ago. The OP was creating a record, then a related record. Do we have an ERD here? It sounds like there's an Application, Volunteer (Contact perhaps?) and Volunteer_Shift? Does the Volunteer/contact record already exist and in what direction do you want to create the lookup? Application to Volunteer/Contact to get that record's ID or Volunteer to Application to put Application as a related list? – crmprogdev Feb 2 '16 at 15:04
  • Can you try with hard-coded ID both 15 and 18 digit id to make sure that its problem with id. I have used both types of id and and never faced any issue. – AtulRajguru9 Feb 3 '16 at 4:26
1
+25

It's hard to see what's going on from the diagram, which looks to be an older version of process builder.

It shouldn't make any difference whether it's passing in the 15 or 18 char ID.

In the new version of Process Builder, you should choose to populate the Volunteer Application field (as it looks like you're doing), then select the type as "Reference" then select the Id for the application object, which may be called "Volunteer Application ID" or simply "Record ID".

Make sure to activate the new version of the process flow as well!

0

For the record, the 18 digit ID is best used in a lookup. I just fixed a process that wasn't working to assign specific lookup record (entitlment) based on a Case record type -- it kicked in with the 18-digit IDs, but not 15-digit IDs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.