3

To begin with, I downloaded Git, then I loaded Sublime Text 3 Windows 64 bit, when I try to download MavensMate.exe file, I got the following error -

enter image description here

After dabbling with the mavensmate installer, I finally got to the point where I could see the ability to create a new project. however this is the error I get when trying to create new project

enter image description here

As suggested in the error installed the latest version of mm by going to MavensMate > MavensMate API (mm) version...

Can someone please help. Thanks.

1
  • I've never seen this before. I'd suggest uninstalling sublime 3 and doing a clean re-install. Also, are you the administrator on the machine you are installing this on? – Anup Feb 16 '15 at 16:41
1

Have you tried installing via the Sublime Text Package Control? http://mavensmate.com/Getting_Started/Users

3
  • I got past the error. However when I go to MavesMate > Project > New Project nothing happens. I was expecting a webpage to open. I do have Chrome as my browser. and i have set the absolute location where I want my MavensMate project to reside"mm_workspace" : "/Users/<username>/Documents/workspaces/mavensmate", any suggestions? – user4947 Feb 16 '15 at 21:06
  • Ok, so after dabbling with the mavensmate installer, I finally got to the point where I could see the ability to create a new project. however this is the error I get when trying to create new project – user4947 Feb 16 '15 at 22:16
  • Which error exactly? – Quicksilvr Feb 17 '15 at 9:56
0

This website helped me install MavensMate with Sublime Text 3.

https://blog.nraboy.com/2014/11/use-mavensmate-sublime-text-apex-development/

0

Please take a look here: https://vishnuvaishnav.wordpress.com/2015/08/20/how-to-setup-mavensmate-in-sublime-text-for-salesforce/ In the blog please see Point: F. Setup Directories : 1. Go on MavensMate > Settings > User. 2. Go on MavensMate > Settings > Default. 3. We have to setup dir in both files. Find out “mm_workspace” : “”, Put you dir here like if your dir is E:\ST then type it will be : “mm_workspace” : “E://ST”, Do same things for both files and save both files.

The issue is you are not setting your workspace dir. So sublime is not finding a place to store data.

I hope it will help.

1
  • Can you please post the exact cause on the answer instead of pasting the link to your blog.? – Jarvis Jan 25 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy