1

I am trying to install Force.com Eclipse IDE Plugin for Eclipse Juno 4.2 but i am getting error like Force.com IDE 31.0.0.201406301722 (com.salesforce.ide.feature.feature.group 31.0.0.201406301722) requires 'org.eclipse.jdt.ui 3.8.2' but it could not be found .

Can someone please help me with this error?

2
  • I'm voting to close this question as off-topic because Eclipse is best supported by the documentation and help available from eclipse.org
    – crmprogdev
    Feb 16, 2015 at 19:36
  • @crmprogdev I disagree, I've seen this issue couple of times and would see the Q & A as a valuable reference for future developers trying to install the plugin with the ide. The documentation doesn't cover this failure or error code.
    – Anup
    Feb 16, 2015 at 22:23

2 Answers 2

1

I have seen this error with Juno before, I would suggest installing Kepler instead since the plugin supports both versions. Make sure you choose 'Eclipse IDE for Java Developers' distribution.

More info here.

2
  • Thanks for reply @Anup . I tried to install Force.com plugin on Kepler too but its prompting the same error. Feb 20, 2015 at 7:09
  • Are you installing the plugin behind a firewall?
    – Anup
    Feb 20, 2015 at 7:46
0

Try downloading Eclipse classic Standard/SDK and update to salesforce plugin with http://media.developerforce.com/force-ide/eclipse42. It worked for me. Once you updated with the force.com plugin, you can later update the eclipse sdk to the latest version if needed.

http://www.eclipse.org/downloads/index-helios.php http://www.eclipse.org/downloads/packages/eclipse-classic-42/junor

Not the answer you're looking for? Browse other questions tagged .