5

We've enabled Chatter in a sandbox but we do not see the option to actually create a new feed item in the UI, even as an Admin. I can create them via Apex so I don't believe this is a permissions issue. We can see feeds, like them, add comments, etc. Just cannot create them. Anything I might be missing? (We are employing the Profile Based Rollout)

  • You may like to check below permissions “Create and Own New Chatter Groups” (ChatterOwnGroups) “Create and Share Links to Chatter Files” (ChatterFileLink) “Invite Customers To Chatter” (ChatterInviteExternalUsers) “Manage Chatter Messages” (ManageChatterMessages) “Moderate Chatter” (ModerateChatter) “Moderate Chatter Feeds” (ModerateNetworkFeeds) “Use Case Feed” (ViewCaseInteraction) “View All Data” (ViewAllData) – Mohith Shrivastava Feb 11 '15 at 13:49
  • Thanks for the reply Mohith. But I was pretty sure it wasn't a permission issue. See Christina's answer below. – Toye Begbaaji Feb 12 '15 at 14:37
3

You may also want to take a look at the "Global Publisher Layout" and check what Quick Actions you have in the Publisher Layout.

For example, if the "Post" action is included there and is the first one in the list, you should see the "Post" publisher in your Chatter page. You use that publisher to create a text feed item.

  • Thanks @Cristina! That's what it turned out to be. A colleague had made a similar suggestion and that resolved it. I had never had to make modifications there in the past so I was oblivious to its important. – Toye Begbaaji Feb 12 '15 at 14:36
0

Make sure the chatter tab is enable for the user profile. After chatter is turned on for the org, and you give certain profiles access. You can choose the Salesforce chatter app from the app picker.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.