0

I have an issue where Contacts are failing to enter a Journey Builder Interaction and I can't figure out why this is occurring. I have spent a couple of hours on this and tried:

  1. Recreating the sendable Data Extension (used by the Attribute Group)
  2. Creating a new Attribute Group
  3. Creating a new Trigger with a different Contact Filter Criteria

Contacts fail to enter the Interaction each time. This was definitely working before and I am following the exact same set of steps that I used previously.

I have managed to isolate this to the Trigger, as I:

  1. Created a new Trigger from Trigger Administration with the criteria [EmailAddress IsNotNull] (so all Contacts enter the Interaction)
  2. Set the Trigger to Test Mode
  3. Added records to the Data Extension
  4. Fired the Event using Contact builder
  5. Viewed results

When I view the result of the Trigger in Test Mode I see 100% failed.

Trigger View Results

When I view the Contacts from Contact Administration, I see that the Interaction Event was queued and handled, but then failed:

Contact Administration

I'd understand if it was failing if the Contact DidNotMeetEntryCriteria but this isn't the case in this instance. It just fails without any helpful reason why this is occurring.

I'm getting the same issue each time. The Trigger ID is 6576f203-e680-4870-b6c0-9cdf9a0691f7.

Please can someone advise how I can debug this further? I've exhausted all options at this stage.

1
  • A colleague has also tried firing an Event for an Interaction that was working last week but it's now failing for him with the same error. Nothing has changed in our environment so perhaps this is a bug that has been introduced with a recent upgrade in the past few days? Is anyone else able to get Contacts to enter any Interaction? Feb 9, 2015 at 3:59

1 Answer 1

0

To find a more descriptive error message. In Chrome Dev Tools:

  • Network tab, clear all data.
  • Navigate to JB Admin/Contacts. (where you are seeing InteractionEventFailed)
  • Click on the route: interaction/v1/interactions/traceevents/search
  • Network tab/Response tab: a more detailed error is probably in there telling you why it failed.
8
  • Hello Drew, thanks for the tip. I tried this and just see an object array of undefined values: undefined: [{undefined: [1423422758854]}, {undefined: [1423422758698]}, {undefined: [1423422758682]},…]. I think the answer is in the response tab (refer to this gist) which includes the error "ExactTarget.Core.Common.Services.Exceptions.ServiceOperationException: An exception occurred while fetching the requested Keys by ContactKey." Are you able to get any Contact to enter an Interaction? I think this is a new bug in current release. Feb 9, 2015 at 16:47
  • Hi Eliot, I just triggered my interaction and it worked fine. On your ContactGroup/DE link, make sure 'Use as root' is checked so new contacts will enter the interaction. Also, make sure the key names you're passing in are correct for how you setup your data. My DE EmailAddress relates to Subscribers on Subscriber Key. My Contact Model Contact Key is one-to-one on my DE EmailAddress. { "ContactKey":"[email protected]", "EventDefinitionKey":"CONTACT-EVENT-<guid>", "Data": { "EmailAddress":"[email protected]", <trigger condition>, <other stuff> } } Feb 9, 2015 at 18:42
  • Hi Drew, yes that's similar to my config. It's definitely not working for us. I've created a short video demonstrating the steps that I am taking. You can view this video at bit.ly/1CMWxdm Feb 9, 2015 at 22:27
  • I followed your video and my interaction worked. The only thing I did differently was I gave my attribute group a different name than my DE. I have not been successful after renaming the attribute group the same as the DE. Feb 10, 2015 at 0:03
  • 1
    True, not a great workaround. I have notified the engineers that this happened. Your error message listed a DefinitionID: "There is no Attribute with the DefinitionID <guid>" If this happens again, let's find that object and just delete that. I have a feeling that one object was preventing everything else. Feb 10, 2015 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .