1

We have a force.com Sites application for our customer portal, on one particular Visualforce page we have a set of dependent picklists displayed using apex:inputfield.

In Chrome and Firefox this works fine, however, when using IE9 the dependent picklist doesn't populate with any values, no matter what is selected in the parent picklist.

Anyone come across this before/have a workaround. Unfortunately, stopping using IE9 is not an option...

  • I remember facing a similar issue. We had used the field in different outputPanel and that was causing the issue. Can you remove everything from the page except those 2 fields and see how it behaves? – Sam Jan 21 '15 at 11:03
  • Looks like thats the issue - thanks! if you change this to an answer I'll marked it as answered – paul Jan 21 '15 at 11:39
  • I am glad that helped. – Sam Jan 21 '15 at 11:40
  • I am having this issue in chrome only, my dependent list works in IE – manza Jan 20 '17 at 5:39
0

There are some issues using dependent fields inside a <apex:outputPanel> tag in IE9 browser. Moving the dependent field out of the <apex:outputPanel> should fix the issue.

As I had encountered this issue long time back, I am not sure why it was happening, probably an issue with the salesforce internal javascript file (dependent.js or something). When contacted salesforce support they were unable to provide a proper answer on this either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.