3

I am setting up the Mavensmate Sublime plugin and need assistance setting the mm_workspace. I need this variable set as /Users/Name 1/Google Drive/Salesforce/workspace

Here's what I currently have the syntax set as

"mm_workspace" : "/Users/Name 1/Google Drive/Salesforce/workspace",

However I get an error saying the variable is configured properly. I think its an issue with the spaces in the file but what am I doing wrong?

error

  • Have you tried escaping the space in the path name. Like this "/Users/Name\ 1/Google\ Drive/Salesforce/workspace" – Chris Duncombe Jan 20 '15 at 15:50
  • @sfdc_ninja yes, escaping the space in the path name results in an error message "Error trying to parse settings: Invalid escape Packages/MavensMate/mavensmate.sublime-settings:21:19" – John_Henry Jan 20 '15 at 16:31
1

Because this is JSON, you need to escape your backslashes which you need to escape the spaces in your *nix filepath. So it should be something like:

"/Users/Name\\ 1/Google\\ Drive/Salesforce/workspace"

Ugh! Right?

  • This is why I try to make my dev path without spaces.... – Charles Koppelman Feb 20 '15 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.