3

I'm trying to deploy everything from my existing (and fully functional) development sandbox to a freshly created sandbox. One of my classes (JobQueueable) implements the Queueable-interface from Salesforce. This class gives the following error when deploying:

Error: Invalid Interface name provided (line 10, column 27)

I've tried changing JobQueueable implements Queueable to JobQueueable Implements queueable according to this post: https://developer.salesforce.com/forums/ForumsMain?id=906F0000000AlPqIAK This only gave me more errors though.

5

I thought it'd be good to share my solution with you. I ended up contacting Salesforce support and after some messages back and forth it turned out that there's some sort of backend setting that needs switched on:

Tier 3 has enabled the permission "Apex queueable" in this Org. Now, you should be able to implement queueable interface.

Maybe someone can enlighten me as to why this is not on by default?

| improve this answer | |
  • 1
    It's likely that it is so new they want to see who is using it and what for, so they keep tabs on it until asked to enable it. It's not a developer preview or beta, so I don't have any other explanation. – Bradley Delaune Jan 14 '15 at 13:16
  • 3
    Not so. It's already enabled in all of my orgs. More likely, it was a glitch with their update scripts (i.e. some orgs may have been missed). I've noticed that any time a new feature has a BlackTab permission, it almost always ends up not getting turned on in a small number of orgs (no hard evidence, but maybe 1-5%?). – sfdcfox Jan 14 '15 at 16:53
  • Possible, although I created the org in question yesterday afternoon. This may mean it wasn't a glitch in their update scripts? On the other hand, I couldn't find anywhere in the documentation that it is a feature that needs requested before being functional. – Koen Wesselman Jan 14 '15 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.