1

I get the following error when trying to validate and sync my newly created External data source for SharePoint Online in Salesforce: "Status An unknown error occurred while accessing Files Connect."

Also, if I try to access SharePoint Online from the "External Files" in "Select a File to Attach", I get the following error after it has loaded: "We couldn't log you in to Sharepoint Online. Contact your salesforce.com administrator.".

If I try to upload a document from the Files tab and selects the SharePoint Online I get: "An unknown error occurred while accessing Files Connect."

I have set up "Authentication Settings for External Systems" and it says that I'm authenticated.

Also, I have granted access to the Documents App when creating the External data Source, and there everything worked, I accepted and it redirected me correctly after selecting "Start Authentication Flow on save".

I have looked over the only suggested solution I foound on this: Suggested Solution, but it didn't help. I have the following permissions:

 <AppPermissionRequests>  
<AppPermissionRequest Scope="http://sharepoint/content/sitecollection/web" Right="Read"/>
</AppPermissionRequests>

So does anyone have any idea what I could be missing or where it might be an error?

  • I have the same issue. Did you try in your developer org. I am trying this in my developer org. I gave the URL as below : https://.....-my.sharepoint.com/personal/ When I do the validate sync I get an error : OAuth token expired Do you have any idea. Thanks, Prasun – user16733 Jan 29 '15 at 12:34
  • I assume you have obtained your client secret and client ID from SharePoint. Be sure to give the correct url in the callback so the authentication goes through. When do you get this error? – erikduvet Jan 29 '15 at 16:04
1

I found the solution:

I had ".../default.aspx" in the Site URL for the External Data Source. It seems that this is not allowed, removed that and tried again and now evrything works fine.

| improve this answer | |
  • Hey Erik - you can mark this as correct now, so the question shows up as answerd. – metadaddy Jan 22 '15 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.