2

I put a custom object into a managed package, and installed that package into another organization. I can see the custom object in the interface just fine - it shows up under the managed package area, and I can write reports against it, but I'm getting 404s on hitting the REST API for it. I am checking that the namespace is correct. What else should I be looking at? Object permissions? API permissions?

  • 1
    Ah! The Standard User doesn't come with access to custom objects provided by packages. I'm not sure what to do to fix it. – freyley Jan 7 '15 at 23:25
1

When you install a managed package in an org, you have to be sure to choose "Available to all users" in order for everyone to have access to custom objects within it.

Your options now are to either remove and re-install the package selecting this option (the easy way!), or to create custom profiles and reassign all of the users who need access to the new profiles.

One other side note, even when you do have access, remember that you'll need to use the package namespace prefix to access the objects as well.

|improve this answer|||||
  • I did check 'Available to all users' - users can see the custom object in the interface, just not access it in the API. The 'Standard User' profile doesn't seem to have API access to custom objects by default. – freyley Jan 8 '15 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.