I'm try to do some work with Automations from the Automation Studio using the API. Based on what I read in the documentation I should be able to get use the retrieve method in order to do this.

When I attempt this request, the status comes back as "OK", but the results contain one API object with two partner properties, one containing the error message and one containing the stack trace.

The first ,results[0].PartnerProperties[0].Value, has the following value:

Object reference not set to an instance of an object.

The second, results[0].PartnerProperties[1].Value has the following value:

at ExactTarget.APIImplementation.Programs3.Soap.EqualsOperator.RetrieveAutomations(SoapRetrieveContext soapRetrieveContext)\n at ExactTarget.APIImplementation.Programs3.Soap.RetrieveCommandHandler.Retrieve(SoapRetrieveContext soapRetrieveContext)\n at ExactTarget.APIImplementation.Programs3.AutomationImpl.Retrieve(RetrieveRequest request)

My code is below:

var retrieveRequest = new RetrieveRequest();
retrieveRequest.ObjectType = "Automation";

retrieveRequest.Properties = new[] { "ObjectID", "CustomerKey", "Name" };

string requestID;
APIObject[] results;
var status = this.client.Retrieve(retrieveRequest, out requestID, out results);

Has anyone seen this before and is there anything I can do about it, or is it a bug with ExactTarget? Is there any other way to get Automation information via the API?

2 Answers 2


Add the ProgramID to the Properties list when making the retrieve. The Automation object has a few issues with it.

  • Unfortunately that didn't work. It accepted the ProgramID property, but still returned the same result.
    – aaron
    Jan 8, 2015 at 15:23
  • I did some further testing: you must have Program ID, a simple filter, and no ObjectID.
    – mobo
    Jan 9, 2015 at 1:12
  • Thanks, it looks like that worked; however, even though I'm getting an Automation object back it looks like the only data that I can get out of it is the CustomerKey and the ObjectID. Everything else is either null or default value no matter what is in the properties list. Any thoughts on why that is?
    – aaron
    Jan 9, 2015 at 13:44

I've gone round and round on this issue and have identified that on the request you need to include "ProgramID"; however, the API response will provide a "ObjectID". Otherwise, it will return an ET internal ErrorStackTrace.

I've opened a case w/ Exact Target and will update the thread of the case #.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .