0

enter image description hereI have a custom object, say CS in my org. User U1 has profile P1 and P1 has all the crud permission on that object. Still while logging as U1, and try to query that particular object it errors out : sObject type is not supported. Can anyone help what other permission needs to set in order to make that particular custom object queryable for that profile ? thanks in advance

11
  • Are you trying to query from developer console ? or via VF page code? Jan 2, 2015 at 10:47
  • i've tried in VF page code, then also tried from workbench, and the object is not availabe in the queryable object list
    – user59759
    Jan 2, 2015 at 10:49
  • Check if the profile of the User is 'API Enabled'? Jan 2, 2015 at 10:52
  • its working fine for other custom objects, but not for this object
    – user59759
    Jan 2, 2015 at 10:54
  • Please provide the query you were using.
    – snehakem
    Jan 2, 2015 at 11:18

3 Answers 3

1

Please check if one of below things resolve your issue.

  • Make sure there exists a object with API name that you are using. Most likely you are mistaking the object API name. Go to setup > create> Object and check the API name.

  • Go to profile level and check if 'API Enabled' permission is checked.

In your screenshot - The status of the object shows that its in development. This is the issue.

1
  • both the conditions are right in place, profile is api enabled and the object api name is correct, still its failing
    – user59759
    Jan 2, 2015 at 10:56
1

The Deployment Status for the object is set to In Development

1
  • 1
    that is correct ! Jan 2, 2015 at 12:40
0

Do you have any namespace and also Check your profile and user license - sounds like you might have a chatter only license

1
  • it is a Salesforce Platform user and also there is no namespace defined here
    – user59759
    Jan 2, 2015 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .