What is the best naming convention developers around have been using for defining Record names to maintain uniqueness that can also be searched easily :
foreg: opportunity name : Opportunity name_Account_name_unique_identifier
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It only takes a minute to sign up.
Sign up to join this communityWhat is the best naming convention developers around have been using for defining Record names to maintain uniqueness that can also be searched easily :
foreg: opportunity name : Opportunity name_Account_name_unique_identifier
I'd say the convention you've come up with is pretty solid, you may not even want an opportunity name, it could just be <<Accout_Name>>_Oppty_<<unique ID>>
or similar.
You could also include the date in there, but that information is available in the system CreatedDate field anyway so may be redundant unless you're using text search specifically.
The only difference I would make over your convention would be to have the account name first so that they get grouped by account when sorted alphabetically—that said, if your opportunity names form a desired grouping then keep the format you have.
A more complete convention guidelines for APEX programming can be found at https://github.com/anupj/Apex-Code-Convention/blob/master/ApexCoding.txt
Also, this document focuses more on the SalesForce administration side, how to name about every entity. https://github.com/cfpb/salesforce-docs/blob/master/_pages/Salesforce-Naming-Conventions.md
Similar question can be found on SO at What is a good set of naming conventions to use when developing on the Force.com platform? and also contains more SalesForce users feedbacks and point of views.