3

I dont find the Approval tab in the Salesforce1 app. However when viewed on my desktop browser (https://.salesforce.com/one/one.app) I see the Approval tab. Is this a bug or some sort of limitation of Salesforce1 app? Both cases it is the same user login so its not a user rights issue.

I am posting screenshots from the mobile, as well as from the browser below.

Any ideas?

Screenshot from mobile

Screenshot from web browser

Adding setup screenshot from Setup->Mobile Navigation

enter image description here

  • As part of the approval process, under approval page layout, have you tried changing the security settings? – Girbot Dec 19 '14 at 12:37
  • I am the System admin, and also I am able to see the approval request if I click the notification in Salesforce1. Only issue is that I am not able to see the "Approval" tab, so in case I miss the notification, there is no easy way for me to see all the pending approvals. – AslamK Dec 19 '14 at 15:48
0

When each approval process is set-up, it needs to be configured to allow the approval page to accessed from a mobile app. See the following page in Help and look at what it says under the Configure Approval Request Page Layout section.

  • I am able to approve from the Salesforce1 app on the mobile when I click on the app's notification. There is no problem with that. The issue is that I can't see the "Approvals" tab. So if I miss the notification there is no way for me to see all the pending approvals assigned to me. – AslamK Dec 19 '14 at 15:46
  • Ok, you're saying the Approvals Tab isn't visible to you. You may want to go to Setup->Mobile Admin->Mobile Nav and look to see it's enabled for your org. If that doesn't fix if the problem, I recommend you reinstall the app on your device. As an aside, also make sure emails are enabled for the Notifications. Similarly, you may want to check to see if they're enabled for Chatter if you continue to have problems. – crmprogdev Dec 19 '14 at 17:16
  • Its enabled in Mobile Navigation setup page. Updated the question with screenshot. When i go to the Salesforce1 app via the PC browser i am able to see that tab. Only on the mobile it does not appear. Will try reinstalling the sf1 on mobile, but that seems kind of lame. – AslamK Dec 19 '14 at 17:28
  • Its possible that it wasn't enabled when you installed SF1 and unless push notifications are enabled, if you've since enabled the approvals feature, it may not update itself without an uninstall/reinstall. – crmprogdev Dec 19 '14 at 18:42
  • Uninstalling and re-installing didn't help either. – AslamK Dec 20 '14 at 9:51
0

When you go to Setup | Mobile Administration | Mobile Navigation, is the Approval Requests option moved to the right side as "Selected"?

  • yes it is. I updated the question with the screenshot. – AslamK Dec 19 '14 at 16:00
0

Well finally I decided to install the Approval Central for Salesforce1 app from AppExchange. This app is from Salesforce Labs. Probably they want to give this as an add-on instead of a basic feature.

Once this Tab was added, it comes up fine on the mobile device. enter image description here

  • This app is a Salesforce Labs app. So, not by Salesforce R&D, but created by someone from Salesforce and posted as a free listing. – pchittum Dec 22 '14 at 8:08
  • Ok got it @Peter. – AslamK Dec 22 '14 at 8:18
  • No problem...it is curious why Approvals are not a feature in the mobile app. – pchittum Dec 22 '14 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.