7

I have a Customer Portal. It has these tabs:

enter image description here

I also have a Site (from Setup->Develop->Sites) that has Public Access enabled And I have this tab:

enter image description here

However, I should see 2 more tabs: Answers and Articles in my public site.

I made the tabs Default On on the settings page for the public settings. I know for sure that the Public Profile has access to the needed objects (when I set the first page on the site to the Answers or Articles the anonymouse users can see the content).

I understand how addition of tabs works in a Customer Portal, you move them over in the settings from one list to another. But how does it work in a Public Site? Do I have to write some APEX/VisualForce code for that? Isn't there a way to add tabs from the settings somewhere?

Just provide more info - the Answers tab is the AnswersHome (standard) and the Articles tab is something I created. It's tied to a VisualForce page. So it's a VisualForce Tab.

9

This could be one of many issues. 1. Is Answers set up on your org? Setup->Customize->Answers->Settings and make sure it is enabled. 2. Which app are you using as the default for Sites? Go to the app (Setup->Create-Apps), and make sure the Tab is in the 'Selected' list instead of the 'Available' list. The site selected app can be found by going to Setup->Develop->Sites->Clicking on the main site label, Going to public access settings and looking for the default App. ** I'm thinking this is the culprit.

Edit: When you go to Setup_>Develop->Sites->Site label, Click on Public Access Settings, you will see a "Custom App Settings" section (if you do not have the Enhanced Profile User Interface checked). The app checked as Default (see image), is your default app for Sites. Make sure that the app (Force.com app in my case) has the Answers and VF tab selected. Screenshot of Apps Section

The next screen shot is of the Force.com App Screen (Setup->Create->Apps->Force.com). Note how the Answers tab is listed in the Selected Tabs. enter image description here

  1. Make sure the tab for Answers (along with your visualforce tab) is marked as Default On.
  2. Make sure the Sites.com "profile" has access VF page your VF tab is pointed to. If you don't see the VF tab listed on the Sites.com profile, I found that unchecking the "Enhanced Profile View" under Setup->Customize->User Interface Settings solves that as well.
  • The Number 2 helped solve the problem. I had no idea that the Public Site uses an App to display the tabs. But it makes sense now. Thank you. – Alexandru Luchian Aug 17 '12 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.