7

(Warning: SSIS and SQL expert, Salesforce N00b)

Hi All

I have access to the Salesforce UI as My Settings > Personal > Connections, Application = 'SalesForce Developers' (Role = 'Application User ID', not sure if that's specific to my company or has a SalesForce meaning).

I'd like to use the query editor tool 'Developer Console', and have been given the below link to access it. https://workbench.developerforce.com/login.php?startUrl=%2Fquery.php

When I click on the link, it takes me to a login page that does not have editable userid and password boxes, only Environment, API Version, and 'I agree to terms of service'. When I check the checkbox and hit the 'Login with Salesforce' button, it returns the error message in the below image. enter image description here

Question: Does anyone know how to get past this login / what additional privs I'll need.

I'm reading the Query Editor page but it doens't speak to how to gain access to it.

I'm also reading the Using the Developer Console page which speaks to specific privs, but it's not intuitive to me where in the SalesForce UI to look to see if I have these. Thanks in advance. Jim

(Edit) Setup > Manage Apps only has App Menu as a selection.
enter image description here

  • I'm confused by the original question? Developer Console is a part of SFDC, and is accessed by clicking your name at the top, and selecting it from the list (usually below My Profile, and My Settings). The link you were given is for the external tool Workbench (which does have a query tool). They're two different things? – HomerJ Dec 17 '14 at 16:38
  • Thanks. I've very new to Salesforce.com and I apologize in advance for tripping over any terms. When I click on my name in the upper right corner my only choices are My Settings and Logout. – Jim Horn Dec 17 '14 at 19:18
11

You'll need to authorize the app in your org, your profile, or your user.

To authorize all users in the org, you can go to Setup > Manage Apps > Connected Apps, edit Workbench, and set Permitted Users to "All users may self-authorize."

To authorize usage just for your user profile (e.g. System Administrators), go to the same area, but click on the label of the app (Workbench), then add your profile to the list.

You could also add a permission set to the list, then add the permission set to your user account. This will enable access just for you.

  • Setup > Manage Apps only has App Menu as a selection, and when I click on it the screen goes to the Search page with a 'Insufficient Privileges' header. Added screenshot to the bottom of the question, as the comment editor dosn't allow me to add an image. – Jim Horn Dec 17 '14 at 16:32
  • @JimHorn That suggests that you're missing permissions. I'd imagine you need Customize Application and Modify All Data. – sfdcfox Dec 17 '14 at 17:01
  • sfdcfox - Would you know the process to get those privs? Looking at My Settings it's not clear, and my employer doesn't have much of a clue either. – Jim Horn Dec 17 '14 at 19:20
  • You'll need the help of a system administrator. They will probably bed to make you a system administrator or create out update a profile. – sfdcfox Dec 17 '14 at 19:30
  • This seems to be correct. Getting 'Guest Admin' privs from the resident sys admin/goddess, so I'll revisit this once those privs are grated. Thanks. – Jim Horn Dec 17 '14 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.