I apologize if this has been answered but after 5 hours of searching and trying everything I can think so, I can't figure this out.

I've created an app in a Developer account, and after creating and uploading a managed package for this app, I used the "installation URL" to install it into a test Org I created through my partner account. The idea was that 4 custom fields would become part of the user data, so that certain users in an org could be "allowed" to use my app. However, these fields do not appear when visiting Setup->Manage Users->Edit.

Points to note:

1.) I DID add the custom fields to the package.
2.) The fields DO show up in the test org under Setup->Customize->Users, but are not available to actually make use of in the "Edit User" screen.
3.) This does work in the original Developer account, but not in the test Org.

If anyone has any information on why this is happening or how to fix it, I'd be very grateful!


1 Answer 1


For a field to appear it needs to be added to the layout used by each profile. Use Setup -> Customize -> Users -> Page Layouts to see/edit the layout in the test Org.

You can instead include a custom User layout in your package, but it still needs assigning per profile so its hard to fully automate. (An in managed packages upgrades will not update the layout.)

  • @Joel OK then that is good. Are you using a "System Administrator" in the test Org? If not, another thing to check is that the fields have "Visible" checked in the "Field-Level Security" of the profile you are using.
    – Keith C
    Dec 9, 2014 at 22:12
  • 1
    Apologies, I deleted my previous comment because I realized it was a drag-and-drop interface, and I thought I had figured out the issue, but I'm still stuck. Yes, in my test Org the user I'm trying to edit is a "System Administrator'. I checked the "Hidden" vs "Visible" settings on one of the fields, and despite setting it to Visible on ALL profiles and re-uploading/installing the package, it's still not showing.
    – Joel
    Dec 9, 2014 at 22:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .