1

When I select 'Deploy to Server' from the MavensMate menu (Using Sublime 3), the only files that get deployed are .page, .trigger and .cls files. I would expect all files, including objects, layouts, etc. to be deployed. I've included the mm_apex_file_extensions portion of my user settings and you can see that it includes all file extensions. Can anyone tell me how I can get all the files to deploy?

Thanks!

"mm_apex_file_extensions": [
        ".page",
        ".component",
        ".cls",
        ".object",
        ".trigger",
        ".layout",
        ".resource",
        ".remoteSite",
        ".labels", 
        ".app",
        ".dashboard",
        ".permissionset",
        ".workflow",
        ".email",
        ".profile",
        ".scf",
        ".queue",
        ".reportType",
        ".report",
        ".weblink",
        ".tab",
        ".letter",
        ".role",
        ".homePageComponent",
        ".homePageLayout",
        ".objectTranslation",
        ".flow",
        ".datacategorygroup",
        ".snapshot",
        ".site",
        ".sharingRules",
        ".settings",
        ".callCenter",
        ".community",
        ".authProvider",
        ".customApplicationComponent",
        ".quickAction",
        ".approvalProcess",
        ".html",
        ".apxc",
        ".apxt"
    ],
1

The mm_apex_file_extensions property only affects which files MavensMate considers an Apex file. You need to make sure that either your project.xml file contains the relevant data, or that you manually select the proper metadata types and files to deploy when you use the Deploy to Server command.

  • Charles is correct. You can also adjust these settings on the edit project window in the project metadata tab. – BrBarr Jul 27 '15 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.