1

I am trying to activate a interaction in journey builder but it gives me a general error message. This is a custom trigger that is built using the hubexchange app. Is there a way to view what the specific error is?

enter image description here

I have tried trying multiple things in from the legacy to the new platform api. I have read through the trouble shooting section as well.

https://code.exacttarget.com/app-development/journey-builder-development/platform/creating-platform-triggers.html

I can activate a event that is not my custom trigger event. Trigger and activity seem to load find in the journey builder. I my example activity I don't have a custom activity, just trying to publish my custom trigger. I am using example code https://github.com/ExactTarget/journey-builder-custom-hello-world

I don't see any errors in the browser inspection related to trigger. I am currently using chrome 39.0.2171.71 (64-bit).

2

Sorry to hear you're experiencing a problem activiating your Interaction.

You can in fact find more detail. Open Developer Tools in Chrome, Click Activate on your Interaction, and under the Network Tab search for publishStatus. Check the response for this request and it should include an error code and a more specific message.

Typically we see this error when there is an issue with activating an interaction which contains an email activity which has an incorrect personalization string stored but there could be a different less frequest issue.

We also will correct the generic message so that more detail will be available on the canvas in the future.

Please let me know if you require any further assistance.

| improve this answer | |
  • I see the error message, """ 0: {errorDetail: "There is no Attribute with the DefinitionID 'ece15cd0-8893-e311-b943-78e3b50b4f00'.",…} errorCode: "ValidateAttributeId" errorDetail: "There is no Attribute with the DefinitionID 'ece15cd0-8893-e311-b943-78e3b50b4f00'." status: "Error" """ Sounds like I am missing something. I still dont know what I am missing. – markz Dec 9 '14 at 21:20
  • Check the filter on your trigger. Has a contact attribute recently been deleted? If so, then the attribute originally configured will not be found and this error thrown. – Jake Miller Dec 10 '14 at 22:20
  • I've come across this too. It would be helpful if Journey Builder has better error handling then throwing a generic 'You are experiencing a server error' message — perhaps provide information on what the cause of the error is. – Eliot Harper Dec 11 '14 at 17:32
  • Hi Jake, I'm getting the same error. I've tried deleting triggers, Attribute Groups, Data Extensions and starting over, but I still can't activate a simple Interaction. I've tried adding different activities to the canvas, but still get the same error. The publishStatus error is {"status":"Error","errors":[{"errorDetail":"There is no Attribute with the DefinitionID '6f0f26c2-50b1-e411-aea6-38eaa71427a1'.","errorCode":"ValidateAttributeId"}]}. The WDF for the Interaction is in this gist. Please can you advise what is causing this? – Eliot Harper Feb 10 '15 at 19:46
  • Hi Eliot, can you create another video showing how you are creating this scenario? – Drew Simmons Feb 10 '15 at 20:11
0

I have had the same problem. However after debugging it I found out my email was not complying with can spam.

I had to add

 <p>
    %%Member_Busname%%
    <br />
    %%Member_Addr%%
    <br />
    %%Member_City%%, %%Member_State%% %%Member_PostalCode%%
    <br />
    %%Member_Country%%
  </p>

in my email then test it. After making sure it was sent. I went back and referenced the email. Then voila worked perfectly. Make sure to test your email

| improve this answer | |
  • this was a custom activity, not related specifically to email, I encountered that problem too before I think your missing a profile center url, <a href="%%profile_center_url%%">Profile Center</a> – markz Feb 9 '15 at 21:47
  • It was included already the profile center – Einstein Feb 10 '15 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.