2

What is the best way to test your Community before publishing? I want to see if Field-Level Security and Sharing Sets are working correctly for the Community User role.

For example, my profile has Admin access, so when I login all fields are visible to me. How can I login as a Community User so I can see what record visibility they have?

1 Answer 1

2

Like everything else, you should test this in your developer sandbox first, preferably in a full copy sandbox that mirrors your production setup and acts like a pre-prod.

Presumably you have communities enabled in your sandbox, you should make your changes in there and then create yourself a communities user to log in and test it without fear of affecting live users.

Once you are satisfied, deploy your changes to production.

4
  • Hi Anup, Thank you for your response! The main problem that I'm having is that I'm unable to login to my community under a test account. I've set my up members up so far to be Support Administrator and Community user. I've created some test users with this role, and members of my team are also under this role. I've successfully reset my password for the Community and when I use the 'Share before publishing' URL, I'm unable to successfully login to any account. After logging in, I'm immediately taken back to the login screen with no error messages. Any ideas? Best, Kevin
    – Kevin
    Dec 2, 2014 at 5:44
  • What happens if you don't use the 'share before publishing' url? Are you then able to login?
    – Anup
    Dec 2, 2014 at 7:47
  • Thank you for your response. I can see the Community if I go to setup > customize > communities and then preview/make changes from within the community designer. I don't know how else I'd be able to login to the community under a test account I created.
    – Kevin
    Dec 4, 2014 at 0:45
  • So far what I've done: 1. Cloned the community profile and labeled it "Client Community" 2. Created a test Contact 3. Selected "Enable Customer Customer User" 4. User license I've assigned to the User is Customer Community and the assigned Profile is "Client Community User" 6. Shuttled over member roles Customer Community User, Client Community User, Support Admin. 7. I try to login using the test credentials I've created. The page looks like its loading, it then refreshes and takes me back to the login screen with no errors.
    – Kevin
    Dec 4, 2014 at 0:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .