0

I get this error every time I try to create a new user for community. Why?

Your request cannot be processed at this time. The site administrator has been alerted

I have selected allow external user and self-registration.

4

Your registration page may be using an email address as the Username of the Salesforce user record. User names need to be unique, so registration will fail if the email address has already been used as the Username for another salesforce user id.

| improve this answer | |
  • This suggestion worked like a charm ... just changed the email id to something which is not used by any User in the Org during self registration ... – sHiBuKaLiDhAsAn Oct 1 '19 at 3:27
3

Amazing what a google search can find........

http://carvingintheclouds.blogspot.com/2014/09/your-request-cannot-be-processed-at.html

  • The community is not published. In case you're working with a community that is offline or in Preview status, you need to publish the community before self-registration will work.
  • The Account Owner does not have a User Role assigned. If you're creating a new Account record on the fly, especially in B2C situations, you need to make sure you assign a default account owner that also has a User Role value. Any role will do, and you can use either a workflow rule or Apex to perform the assignment.
  • The site guest user does not have Create and Read permissions on the Account and Contact objects. Edit Public Access Settings for the community's Force.com site to grant these permissions, along with field permissions for any fields that are included on the self-registration form. Note that by default the site's profile will not have these permissions.
  • Self-registration is not enabled for the community. Go to Manage Communities, click Edit and make sure the Login settings show that self-registration is enabled.

If that does not answer your question then try one of the many other results:

http://lmgtfy.com/?q=salesforce+Your+request+cannot+be+processed+at+this+time.+The+site+administrator+has+been+alerted

| improve this answer | |
0

Even I had same issue and when I checked Trailhead account email, could see the error - "portal account owner must have a role" then assigned a Role.

That worked perfectly!!

| improve this answer | |
0

Check your email (or ask the sys admin to do so if you are not the admin). It will have the actual error message in it.

Very often beside of the mentioned reasons, the reason for this error is the ProfileId missing

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.