7

I'm starting with Aura/Lightning today and want to install this plugin for sublime on Windows 64bit

So I followed the instructions in this video here https://www.youtube.com/watch?v=A_sUTfeGKxw

It requires this https://github.com/heroku/force

Unfortunately all binary downloads are broken:

Then I tried to compile it from source, proceeding these steps:

This also did not work and resulted into the following error:

D:\elastify.net\apps\force>go get -u github.com/heroku/force
go: missing Mercurial command. See http://golang.org/s/gogetcmd package github.com/heroku/force
    imports bitbucket.org/pkg/inflect: exec: "hg": executable file not found in %PATH%
go: missing Mercurial command. See http://golang.org/s/gogetcmd package github.com/heroku/force
    imports github.com/ViViDboarder/gotifier
    imports github.com/ddollar/config
    imports github.com/ddollar/dist
    imports bitbucket.org/kardianos/osext: exec: "hg": executable file not found in %PATH%

Any go-experts here? Sure I'm making stupid mistakes... but today it's the first time I heard about go... :-)

Or any ideas where to find those binaries? (I would prefer the binaries to keep this part simple and focus on Aura as soon as possible)

2 Answers 2

3

I've pinged DaveC about this to see if we can get it corrected. I hit similar stumbling blocks when I first built from source but I did eventually get past them. The hg issue is either a path problem (I seem to recall having to add it to my path manually) or perhaps you have not installed this dependency? Waiting for the binaries to come back online is not a bad idea - getting my Go environment setup, learning the basics of how to compile/run/debug etc was "entertaining"...

5
  • I got an out of office auto response from DaveC. I should be able to build the binary(s) for you to get you running until he is back to fix the root issue. What operating systems do you need? Nov 28, 2014 at 21:40
  • Created new issue on the forceCLI github site github.com/heroku/force/issues/122 Nov 29, 2014 at 12:49
  • I have shared my build (from the latest source from github) of the 64 bit OSX force binary here dropbox.com/s/dke34xb7pptrw3q/force?dl=0 Nov 29, 2014 at 12:58
  • 1
    This issue has been resolved. Links now work. Dec 12, 2014 at 23:45
  • late response on my end, but thanks for fixing this!
    – Uwe Heim
    Feb 25, 2015 at 17:55
0

The missing "hg" command is from Mercurial. Download and install that first, and the steps you suggested should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.