3

My issue is after putting a lookup input field into a table, although it displays properly and by clicking the lookup button it can successfully open the lookup dialog, it can't select - When I click on one result in the lookup dialog, it doesn't pick it up.

My code generally looks like this:

<table class="wTableInfo1" cellspacing="0" cellpadding="0" border="0">
    <tbody>
        <apex:form >
            <apex:repeat value="{!$ObjectType.Order__c.FieldSets.Request_Mandatory}" var="f"> 
                <tr>
                    <td>{!f.label} <span class="required">*</span></td>
                    <td><apex:inputField id="OrderDetailsField" value="{!parentOrder[f.fieldPath]}"/></td>
                </tr>                                                 
            </apex:repeat>   
        </apex:form>    
    </tbody>                            
</table>

I have tested by moving the apex:form section out of the table and removing all the <td>, <tr> tags and it works fine for me. But if I put them in a table, the lookup field stopped working. It seems that it turns into readonly after putting in a table. This issue can also be replaced without using fieldset.

Any thoughts?

0

Did you try this?

<apex:form>
<table/>
</apex:form>

submit action should be within apex:form

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.