0

I have a lookup field on opportunity object. The field is a lookup to account object. The filter criteria i had used is that only accounts of specific recordtype should be available in the lookup. The filter is also made required.

However when i clicked the lookup, no records are retrieved. I manually opened the related record to check if it shows recently viewed records. That did not work out too. I tried searching for records too. Even then no results showed up. Is there any other setting that needs to be enabled ?

  • 1
    Your filter may not be setup correctly. If you provide a screenshot of the filter you have setup people may be able to provide more help. – BarCotter Nov 26 '14 at 12:08
0

Filtered Lookups windows will not suggest you with a result set. You need to search first and and then see the result list. You have to type the Name field /External Id field/ other fields of the Account field that you have configured (in Account object setup) to be available for search through lookup dialogs.

  • Tried that too.. But did not work – SFDC Learner Nov 26 '14 at 12:07
  • (1) Did you try enabling Enhanced lookup for Account in Set up -> Customize - >Search -> Search Settings? (2) Did you include fields in the Lookup filter fields OR Search Filter Fields in the Search Layouts of the Account? – Vignex Nov 26 '14 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.