4

I have a simple visualforce page which loads a canvas app, the code looks like this:

<apex:canvasApp applicationName="AppName" 
    namespacePrefix="namespace_prefix" 
    height="1080px" width="100%"/>

It works fine in my developer account, and worked previously when I uploaded new "released" versions of the managed package, but as of today when I uploaded a new version of the managed package and upgraded to it, I got the following error when opening the Visualforce Tab which points at the above Visualforce page.

Force.com Canvas can not locate an installed canvas app with the namespace [namespace_prefix] and API name [namespace_prefix.AppName].

I then went and looked at the VisualForce page on the organization I had installed the package onto and I found the apex:CanvasApp code had changed!, on the org I upgraded the package on the Visualforce Page looked like:

<apex:canvasApp applicationName="namespace_prefix.AppName" 
    namespacePrefix="namespace_prefix" 
    height="1080px" width="100%"/>

If on that org I make a new Visualforce page that does not have the newly added "namespace_prefix." everything works fine and my canvas app loads up, but I cannot find a way to get my managed package to deploy the Visualforce page without adding the unwanted "namespace_prefix." to the applicationName, I also tried switching to using developerName instead of applicationName but the exact same thing happened.

It seems that this can be circumvented by uninstalling and reinstalling the package, but this is an unacceptable solution for our customers

  • It sounds like you shouldn't be providing namespacePrefix attribute on the canvasApp, since it is automatically adding the prefix to the applicationName. – sfdcfox Nov 24 '14 at 20:35
  • I tried that, it doesnt help, then the error just becomes Force.com Canvas can not locate an installed canvas app with the namespace [null] and API name [namespace_prefix.AppName] – user8246 Nov 24 '14 at 20:36
  • 1
    Not sure if it matters, but are you using the App Name or the DeveloperName for you canvas app? You do have the option to use both. Have you tried the other? salesforce.com/us/developer/docs/pages/Content/… – Double A Dec 9 '14 at 1:26
  • I tried both, the same thing happened – user8246 Dec 9 '14 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.