2

Looking through the VisualForce Developer's Guider, there is information on how to create a dashboard with VisualForce.

I have no problem adding a VisualForce component or selecting the VF Page as the "Data Source", however instead of displaying the rendered page, I just see the bottom-left most VF-XML:

enter image description here

2 Answers 2

1

I was facing the same issue.I figured this was happening only for the VF pages which I create and not for any VF pages of managed packages. Increased the height of the dashboard component to see that, the page was actually being rendered, but not just the VF page.The VF page plus the page editor.

I disabled the development mode from the user profile, and now the page renders correctly in the dashboard component. Looks like Salesforce expects the dashboard to be run in non-development mode / by a non developer user.

1

Yes. You need to disable Development Mode in order to get only the component to be displayed in dashboard component.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .