When I try to build a new project (MavensMate->Project->New Project) in Sublime Text 3,the console displays the message:

"[OPERATION FAILED]: Could not find the mm executable. Please run MavensMate > Install/Update MavensMate API (mm) to install mm to your MavensMate for Sublime Text plugin directory."

and i run (MavensMate > Install/Update MavensMate API (mm)) but it doesn't work

  • Have tried removing the mavensmate plugin and then reinstalling it? That has helped me in the past. Commented Nov 14, 2014 at 14:01

3 Answers 3


I recently got stuck with this error while I was trying to create a new project. I found out that I forgot to setup the path of my workspace directory under the "default" setting. However, I did setup the path of my workspace for the "user" setting. The paths for the both should be the same.

Steps: 1. MavensMate > Settings > User (Set the path on this line: "mm_workspace" : " put your folder path here ") 2. Repeat the same thing but with the following steps: MavensMate > Settings > Default

It worked for me. It doesn't hurt to try!

  • Worked for me too. My user setting for mm_workspace was using the wrong installation directory. Thanks! Commented Nov 11, 2016 at 16:00

When I had this issue it turns out it was because I'm using the portable version of Sublime Text 3, when you do this apparently there are some inherit issues with your paths.

jow5 from this thread provided the solution that worked for me, by creating a junction for "Sublime Text 3" in %APPDATA% that targets the Data folder.

For example:

`mklink /J "Sublime Text 3" "C:\Path\To\Sublime Text\Data"`

Not sure whether you are still stuck in this error. If so,

What Mavensmate does here is simply check whether mm.exe (mm if your Os is Linux or Darwin) exists under your sublime package\User\Mavensmate\mm folder. Your sublime package location may differ due to different operating system. On Windows, it is usually C:\Users[Your user name]\AppData\Roaming\Sublime Text 3\Packages.

So one simple way is to go to that folder and check whether it is well installed. I bet it is not. To check the issue with your installation, you can click ctrl+` to see the debug logs. Unfortunately, I don't see a manual installation for mm API.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .