Can anyone shed some light on this error? I cannot connect to either Production OR my Sandbox with the IDE. :-( Thanks.

Screenshot of failure

This happens after entering user/pass/token in and selecting to get "all". I've tried searching keywords from the error but am coming up with no help.

Windows 7 64-bit with 64-bit IDE standalone package.

  • Can you try installing eclipse and then force.com plugin ?Or may be go for fresh installation that should be helpful Commented Dec 19, 2012 at 17:44
  • Definitely related to JDK 1.7. You don't need to fully uninstall 1.7, although that's the easiest solution; alternatively, make sure that forceide.ini has a -vm switch pointing to a 1.6 JDK (in addition to the suggestion of unchecking any 1.7 JRE's inside eclipse).
    – jkraybill
    Commented Dec 20, 2012 at 5:16

5 Answers 5


This error is presented (not just during deployments) when Java7 (1.7) is installed.

Removing Java7 from the machine so that Eclipse cannot reference it, should revert you back to having just the 1.6 JDK available and you'll be back in business.

Worst case, remove all installed versions of Java and then download & install JDK 1.6 again. If you're running a 32-bit version of Eclipse be sure to install the 32-bit JDK.

this happenns when JRE is updated from 1.6 to a higher version. The way i handle is by going to Window -> preferences in ForceIDE top menu.

another alternative is, You will get a dialog window, Click on Java ->Installed JRE and uncheck jre7. Restart ForceIDE it should work.

enter image description here

  • I appreciate the info. I ONLY have 7 installed at this point, and since my own solution ended up solving it (only loading classes and triggers which is what I'm working with), I'm going to stick to that for now until it becomes necessary to load more and it fails again (and I then have to go get JRE6 to install (sigh)). Thanks!
    – AMM
    Commented Dec 20, 2012 at 14:11
  • On second thought, I'll follow the advice of those who know 28x more than I do... thanks again. ;-)
    – AMM
    Commented Dec 20, 2012 at 14:21
  • For the sake of following up: JRE6 does NOT solve the problem. I switched to JRE6 solely, restarted completely IDE, and still could not load "all" from SF. But CAN load just classes and triggers. (shrug)
    – AMM
    Commented Dec 20, 2012 at 14:50

This looks to me an error because you have the latest version of jdk installed and force IDE is not compatible with it.

The way i handle is by going to Window -> preferences in ForceIDE top menu.

You will get a dialog window, Click on Java ->Installed JRE and uncheck jre7. Restart ForceIDE it should work.

You can look at answer from Mark ponds and my answer with screenshot to a similar question. In Force.con IDE - Error while deploying to Server


This is an overwealming Pain...

You can try this: http://www.myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

basically adding -clean and then running eclipse

Something else you can try if that fails:

  1. create a new project
  2. Delete Eclipse and reinstall
  • Didn't help, unfortunately. I even installed the most recent JRE just to be sure. (sigh) This bites.
    – AMM
    Commented Dec 19, 2012 at 19:47
  • Interesting... on a whim, I tried NOT loading "all" and just selected CLasses and Triggers (which is what I care about). That worked. Weird.
    – AMM
    Commented Dec 19, 2012 at 19:52

Just loaded Classes and Triggers, after trying reinstallation, the -clean switch, deleting/recreating the projects, etc.


An answer was obtained on HOW TO DELETE TRIGGERS/CLASSES from Production in another thread: Deleting a Class with IDE - cannot delete from Production?

The specific answer to this one is unclear as another JRE was installed (but I stuck with JRE7), AND other things were tried. It is suspected that the JRE solved it, but I am unsure. :-/

Thanks to all who helped!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .