2

I would like to know if there is any procedure to add the contact to the community group. In my org, we have a trigger which creates a contact, when external user signs into the community. But when I click on "add members" in my group detail, it shows only internal users and not external users. Is there any way I see external users also in the list, where I can add them to community group?

Thanks in advance

  • 1
    What is the default sharing for Users? Where does the group reside? Chatter Groups have a community scope, which means groups in the community cannot be seen internally and vice versa. – greenstork Nov 11 '14 at 16:21
3

Community Users are created from Contacts who are not currently Users. From a contact's detail page, click on the button labeled "Manage External User". You should get a drop-down that says "Enable Customer User" (assuming you have a Customer Community). Select that option to enable the contact as a Community User.

From there, it will take you to a New User Screen where you'll need to make certain you've selected the correct User Profile to use for the contact in your Community and whether or not to enable various features for them like Chatter along with setting their User Name, Alias and so forth.

For more detailed help instructions, see Creating Community Users.

Edit 1 See Screen Capture below of what to look for from Contact Detail Page. If you don't see the Button and Drop-down circled in red, then you may need to edit your Detail Page layout.

Contact Detail Page - Manage External User Button

Edit 2 As your Contact is already has access to your Community, they're a Community User and you do not need to create a new User. Instead, it sounds as though your issue is one of permissions. Either the User doesn't have the correct profile assigned to them that gives them access to Chatter, or they've not been added to a group and given assigned a permission set that gives them that access. Since I don't know what the security model is for your Org, that's not something I can sort out for you. I'm guessing they likely self-registered.

What I would do to find them is from within Salesforce, go to Setup > Manage Users > Users > click on Create New View and use the settings you see in the following screen capture:

Create New View - Self Registered Community Users

This should provide a new view listing Self-Registered Community Users. Find the User you're looking for and edit their details. Look to see if Chatter is enabled for them or if there's a different Customer Community Profile available that has Chatter enabled in it that you can reassign as their profile. They may need to be added to a group of Community Users and assigned a permission set in order to add the Chatter Enabled permission for them. Its also possible that their Contact isn't associated with an internal Account or some other criteria along those lines. You'll need to determine what your org's security model is to resolve those details.

As resources, I'd point you to the following: Getting Started with Communities, The Force.com Fundamentals Workbook, The Security Workbook and The Force.com Workbook.

  • Thanks a lot for you reply. I have tried this step. But the problem still exists. I click on my Community ( as an admin). I clicked on "Add members". The list shows only internal users. The external users, are not being shown at all. When I login as Customer User and click on "community group" tab, I get insufficient privilege error. – PSH Nov 10 '14 at 3:26
  • Do this from inside SF by clicking on the Contact. The directions were intended to be used from within the regular SF interface, not from within the Community. Again, take a look at the link I referred you to for step-by-step instructions. You'd need to have Community Manager Privileges to do much from within the Community and that's primarily for administering existing users. – crmprogdev Nov 10 '14 at 3:45
  • 1
    I will continue to try to assist you as time permits but please remember that I'm a volunteer here, not an employee who staffs this site. Now that you've clarified the Contact is already a User, its clear the issue is one of permissions. See my updated answers above. BTW, you can edit your post at any time to add a screen shot. The edit button is at the lower left corner. – crmprogdev Nov 11 '14 at 15:17
  • 1
    @user3303348 you can update your question with additional info or screenshots. Try to have your question as the single source of info around your question, and let no details be hidden in the comments. Updating your question may also attrackt other users with different knowledge. – Samuel De Rycke Nov 11 '14 at 18:28
  • 1
    Thank you very much for your suggestions. @crmprogdev--> Speacial thanks to you sir and I aplogize for having bothered you. I am really grateful to your volunteering. Now the solution was -->. You’ll need to create the group from w/in the community and update custom settings to use the group . This fixed my problem – PSH Nov 11 '14 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.