1

I'm trying to pass contact data to my execute end point for my custom activity, but for some reason, the body remains blank.

here is my arguments section in config.json

"arguments": {
    "execute": {
        "inArguments": {
            "email":"{{Contact.Default.Email}}",
            "first_name":"{{Contact.Attribute.['Email Demographics'].['First Name']}}",
            "last_name":"{{Contact.Attribute.['Email Demographics'].['Last Name']}}"
        },
        "outArguments": {},
        "url": "https://my-public-server/create_lead/execute",
        "verb": "POST",
        "body": "",
        "header": "https://my-public-server/create_lead/execute",
        "format": "json",
        "useJwt": false,
        "timeout": 10000
    }
},

The endpoint is being called by journeybuilder, but it isn't passing anything through.

What am I missing?

  • Welcome to SF.SE Shawn. Just to clarify as it may be helpful to someone else who can answer your question, it appears to me that you're creating leads from inbound email services. Is that correct? – crmprogdev Oct 31 '14 at 13:50
  • Basically trying to create a lead from attributes stored in data extensions. I'm able stuff the values on the end of the URL, but I think it would be better if I could POST the data. – Shawn Crosby Nov 1 '14 at 18:24
  • Shawn, were you able to get this working? – Drew Simmons Feb 20 '15 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.