3

I want to expose the cases tab in an existing Partner Community.

After exposing the Cases tab I am getting the insufficient privileges error when clicking on it. I am able to create a case as a Partner in the Community but after saving I get the same error when hovering over Case in Recent items. The profile has read, create, edit on Cases. The Owner of the case is in the role Sales Operations. Because our org has OWD private on cases I set up a sharing rule, in fact 2 rules one based on the Partner Community Role and the other based on a Public Group that I put the user into. Neither one seems to do the trick. What am I missing?

enter image description here

  • 1
    Did you click the Recalculate button after creating those rules? – greenstork Oct 24 '14 at 15:38
  • Thanks for your reply. I did recalculate Case sharing. Same result. Interesting that I can expose Opportunities tab and create a new Opportunity. The new opp is visible until the owner is changed, then the insufficient privileges error appears when clicking on it. Again, the same is true on Cases, I can actually create a new case on the left side but because it is reassigned immediately it can not be seen after creation. I am still missing something somewhere. – Steve Petrofsky Nov 6 '14 at 16:14
  • Plus even when the case is assigned and owned by the same Partner Community user the insufficient privileges error continues. Please help. – Steve Petrofsky Nov 7 '14 at 12:46
  • That is telling, when the partner user owns the case they still can't see it. Is there a Visualforce page for case view? – greenstork Nov 7 '14 at 14:30
  • Thanks...once I enabled all 800+ Visualforce pages for the profile the user is able to now view the case. Not sure yet which pages were controlling this but at least we know that was the problem. – Steve Petrofsky Nov 12 '14 at 13:31
1

Based on your comments, it looks like the problem is that the Case view is controlled by a Visualforce page. To find the exact page that you would need to enable access for your Partner users, go to Setup > Customize > Cases > Buttons, Links & Actions and scroll down to the View action. On the far right column, you will see reference to the page overriding the View action. You can then go back to your Partner Profile and enable only that page.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.