9

Did anybody try to package salesforce lightning new component framework apps? I tried a managed package and installed it, its not working if i try to access the app like

salesforceinstanceurl/packagename/appname.app

Also if create a unmanaged package I'm not able to install it, it gives me strange error called "validation error during saving components"

I enabled lightning component in my target org before install, I'm just trying to package the expenses sample app given in lightning book.

Thanks

2
  • I just ran into the exact same problem. The /namespace/appName.app URL works fine in my DE org, but in my destination EE org I get the error, "URL No Longer Exists. You have attempted to reach a URL that no longer exists on salesforce.com." – Marty C. Nov 11 '14 at 2:53
  • I close browser then open again, it works for me. – unidha Sep 1 '15 at 7:13
4

For unmanaged packages the namespace can be a source of errors. Typically you need to open anything that references the namespace, for example in markup, ns__Obj__c for object refs, ns__resname for static resources, and so on. We will be supporting non-namespaced orgs and the default namespace concept from Visualforce in an upcoming release, but for now the namespace requirement makes for additional work and attention to detail.

For managed packages the resource "spidering" should resolve any dependencies, and versions of that sample have been distributed successfully. If you'll provide me with an unmanaged package install URL, I will try it out on a fresh org and then create a managed package installer to see if I can determine what might be going on.

Thanks,

Skip

2
  • Here is the sample app, which searches and displays accounts using lightning, styles are not working properly in sf1 app, but the app is functional. I created an unmanaged package, not sure you can install this since its fails at the end saying Validation Errors While Saving Record(s) There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "{0}". Unmanaged package link, login.salesforce.com/packaging/… Thanks – realnumber Oct 24 '14 at 22:50
  • some magic happened, the packaging is working now for unmanaged package. – realnumber Nov 12 '14 at 19:11
0

As of the Winter '16 preview, this is still not working. Our team ran into this issue too and submitted a ticket to Salesforce.

If we switch to an unmanaged package, the App we created is accessible.

0

From Lightning Components Developer Guide; "Mark your resources with access="global" to make the resource usable outside of your own org; for example, if you want the resource to be usable in an installed package or by a Lightning App Builder user or a Community Builder user in another org."

So, please add GLOBAL access modifier to your app like; aura:application access="GLOBAL"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.