8

I'm trying to save a large number of files for an org in a single instance (over 35 files at a time). I'm replacing numerous endpoints to a new remote site, so basically a find/replace across numerous workflow rules. Since this is part of the manual step process after a sandbox refresh, I'm going to be performing this task quite frequently and I'd like to figure out a better approach. Here's the issue:

Anytime I try to run the 'compile_tabs' command it hangs on me.

It will say: 'Operation: Compiling:' and then the Result animation will go on forever and I will have to close out of sublime altogether. I've found the most effective way is to save 7 files at a time, wait for those to finish, check for any errors and save again. Lather, rinse, repeat... Any more than than 7 or so usually results in the 'hanging' issue.

Anyone have any thoughts on this? Can you somehow request to disable parallel saving while saving a large number of files to the server?

I located this question, but doesn't really address my problem specifically: Save/Deploy multiple files at once with MavensMate in Sublime Text 3

My "mm_compile_with_tooling_api" is set to TRUE,

Sublime Text - Build 3065 AND MavensMate for Sublime Text v 4.0.2

Update I did the 'Save All' command after doing "Compiling Selected Metadata" and only 14/35 saves went through successfully. (It also did it over lunch since it seems to take forever, as it appears to try to compile all in parallel.)

  • 1
    You may be better off saving these files with a metadata api deploy after modifying them locally. – Phil Rymek Oct 20 '14 at 16:40
  • Seems like a good case for setting up a grunt task, and just changing credentials as needed for a new deploy. – greenstork Oct 20 '14 at 17:06
  • 1
    Changing "mm_compile_with_tooling_api" to TRUE or FALSE doesn't seem to make a difference. I'll get random errors like Result: [OPERATION FAILED]: The read operation timed out OR it will say Result: Success and it did not actually save to the server. No rhyme or reason to it... – rmarq423 Oct 20 '14 at 17:40
  • Have you tried compiling the project? – Joseph Ferraro Oct 21 '14 at 19:38
  • Are the endpoints hardcoded? Could you reference a custom setting instead? – bafuda May 2 '16 at 21:31
1

The story behind this is every time when you save a file, mavensmate will trigger the on_post_save() event which will automatically force compile file, which doesn't check whether the file is already compiled or not.

This, I believe, should be a feature request or issue with mavensmate which you can post here. It will be hard for mm to handle too many files at a same time so it should add some logic here to do that via batch. But as you can see, their speed in responding to issues is not very high.

Alternatively, you can write a sublime text plugin to do that. The functionality should be simply, you just need to tell whether the list of files' size is greater than 7 and batch handling it if so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.