2

We have implemented live agent recently in our organisation. It works fine except when it comes to the pre chat form. The pre chat form doesn’t pickup the value of the current user. When I try to retrieve the current user using ‘:UserInfo.getUserId’, I get the chat site guess account instead. The chat button lives in the customer portal. We need the information of the logged in Portal user to be displayed instead of the guest user. I was just wondering if anyone has had the same problem and if they are aware of a workaround. Please let me know if you have any suggestions,

Thanks

  • Have you looked at the configuration for your pre-chatnik form if you're using one? Also, do you have more than one site and/or is the Guest login enabled? If the latter, try disabling log-in as a Guest. – crmprogdev Oct 11 '14 at 5:51
1

This would happen if the URL you are specifying in the button configuration uses a different protocol or is in another domain.

I had this issue as well, in my case our portal user was authenticated in

https://support.ourdomain.com

but the prechatform URL configuration was set at http://support.ourdomain.com

This also happened if the user came from https://support.oursite.co.uk

In short, make sure you are keeping the authentication by keeping the user in the same domain/protocol.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.