13

I want to create an "API Only" user but can't find the checkbox to do that. I can see "API Enabled" as one of the checkboxes on the profile and permission set pages but I think that's different. How can I create an API only user ?

4 Answers 4

10

There is an option called "API only" below "API enabled" in profile. If you are looking in developer edition it isn't available but it's there in enterprise edition.

7
  • this is also available in developer edition :)
    – Eric
    Oct 2, 2014 at 16:42
  • Oh is it? I checked in my developer edition but this option was not showing up in profile. Oct 2, 2014 at 16:44
  • yeah it is available :)
    – Eric
    Oct 2, 2014 at 16:46
  • My bad :( I have deleted my answer .
    – Eric
    Oct 2, 2014 at 16:55
  • No problem my dear friend Oct 2, 2014 at 16:57
5

For those that do see it, if you are looking at a dev org created from an existing EE org, you should have it. However, if you are creating a brand new dev org that is not connected/related to an existing EE org, it is not there.

4

This is a permission not a special user. You can create a new API only user by setting permission at profile level:-

  • Create a new User.
  • Create a new Profile or clone existing one
  • In new profile at Administrative section check the checkbox "Api Only User" and Save.
  • You have created an API only user

When you check the API User checkbox, it restrict the permission of UI based login, you can't use credentials to actually log into the Salesforce instance. It count against API user license.

6
  • Is this available in developer edition? Oct 2, 2014 at 16:49
  • @Sethu Developer edition doesn't have this.
    – Ashwani
    Oct 2, 2014 at 16:57
  • @Sethu Developer edition doesn't have administrative section also.
    – Ashwani
    Oct 2, 2014 at 16:59
  • We do have the section called "Administrative Permission" in developer edition. Are you referring to some other section? Oct 2, 2014 at 17:03
  • In dev edition we have system permission instead of administrative permission. Just checked Manage users > Profile > System administrator @Sethu
    – Ashwani
    Oct 2, 2014 at 17:09
2

In addition to the other answers here: you will not see the "API Only" option for the cheaper "Salesforce Platform" licenses. You need to have a profile attached to the full "Salesforce" license for the "API Only" option to appear.

Source: https://ideas.salesforce.com/s/idea/a0B8W00000Gdf77UAB/api-only-platform-user

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.