I'm having an unusual problem where I am unable to search for a particular contact from a contact lookup field on another object. I have full visibility of the contact in question and can search for them with the standard overall search of the Salesforce org, but nothing comes back from the lookup field search.

The issue is occurring for one user, but not for another.

Does anyone have any idea of what might be causing this or how to resolve it?

  • 1
    Can you take the URL of the contact from the user that can see it, and try to access it from the user who can't? What error do you get?
    – Saariko
    Aug 16, 2012 at 16:28
  • 1
    Both users have full visibility of the contact. I can take the URL of the contact and access it under either user. The issue is that the contact is not coming back in the lookup search results - I receive no results.
    – Killian
    Aug 17, 2012 at 9:38
  • 1
    Is it only for this contact? Can your user see other contacts via the same lookup? Wondering if it's maybe field level security...
    – metadaddy
    Aug 20, 2012 at 16:08

4 Answers 4


I have experienced a similar issue and what worked for me was enabling Enhaced Lookups for the object in question. In your case Contacts.

Click Your Name -> Setup -> Customize -> Search -> Search Settings

In my case it looked like there was some filtering going on in the lookup that prevented the user from seeing results. Enhanced lookups got things working for me.

Bowei's case: I have to turn off the enhanced lookup so that records can be displayed. I am afraid there are more bugs in this feature.

  • Not sure this fully explains the problem I was having, but enabling enhanced lookups on the object has resolved it. Both users are now seeing the contact in the lookup search results. Thanks.
    – Killian
    Aug 22, 2012 at 8:53

Is this Contact assigned to an Account? Contacts without Accounts in Salesforce are considered private to their Owner, and anyone with the View All Data permission. This would explain why one (presumably non-admin) user could see the contact (i.e. they are the owner) and one could not (i.e. they are not the owner).

  • The contact is not assigned to a Account and is private, however both users in question have 'View All' permission on Contacts and (as mentioned above) both users can view the contact. The issue is with search results on a lookup field to the contact. The contact in question does not appear in the results for one of the users when searching from a lookup field.
    – Killian
    Aug 20, 2012 at 9:25
  • Out of curiosity, have you tried to parent the contact to an account and re-try the lookup from the end-user's login just to see if there is something about it being a private contact? Also, which user (if either) owns the private contact? Oct 24, 2012 at 19:56

Two things to check:

  1. Are you sure both users have access to the object? Have you tried the global search while logged in as the user?
  2. Are there any filters on the search that may be excluding the target object?
  • Both users have access to the object and the global search does return results. There are no filters on the search or lookup field.
    – Killian
    Aug 16, 2012 at 16:11

There is an option when you are on the global search page. Next to the search textbox there is an "Options" link. Click on the link and deselect:

Limit to items I own

This will solve your problem to see all records for an object when "View All" or "View All Data" for the profile is selected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .