0

I'm running into a strange problem. I am trying to use the standard customer portal search but for some reason only some of my custom objects are visiable there?

I cant seem to figure out what makes one object show up in the dropdown and some objects dont? is there a permissions setting i need to work about? The portal user in question has full access (R, W, E, D) and can view data from taht objects elsewhere in the portal?

Related to that is there a way to use the standard search logic in a visualforce page? I'd rather build a custom page for it but I didnt want ot have to build all the search queries and results layouts from scratch?

Thanks everyone

2
  • Does your custom object have the "Available for Customer Portal" checkbox selected? The option is available on the Edit Custom Object screen in the Optional Features section. Dec 4, 2012 at 3:52
  • Yes that's already checked and the data is showing properly in the portal, but it's just not in the search dropdown. That's the only problem, otherwise it works fine in the portal. Dec 4, 2012 at 17:25

2 Answers 2

1

Goto Setup > App Setup > Your Object > Edit it and check the option "Available for Customer Portal". Then you'll be able to see that object permissions in customer portal profile.

From there you can give access to the object to show up on portal.

1

I figured out what the problem was. Turns out for some reason you have to have the "tab visible" for the object to be searchable in the customer portal. I'm not really using the tabs its all custom visual force pages so i didnt notice that at first

thanks everyone

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .