3

Our managed package is failing to install in target orgs (DE, EE). The error that is thrown during installation is "Unable to Access Page", with a reference to one of the permission sets in the package. The rest of the message is "The value of the "{0}" parameter contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and resubmit. If the error still persists, report it to our Customer Support team. Provide the URL of the page you were requesting as well as any other related information."

I wrote about this issue before and thought I had solved it: Package install worked yesterday, but not today. Very strange error reported

Sadly, it has come back. What I noticed, however, is that the metadata for the permission sets has some extra "stuff" in it (tabSettings to be specific), relative to a freshly-created permission set. So I figured I would just manually remove the XML and re-compile the metadata back to the org. I can save the metadata to the org just fine (no errors)...but the extra XML is not removed.

I think the extra XML constitutes "corrupted" permission sets and of course I want to just replace them with new ones, but I can't remove them from the managed-released package!

Has anybody seen something similar? Any advice for me?

Thanks!

  • Winter 15 is giving nightmares to a lot of people, we are facing out own set of issues with it, so considering the urgency you might want to get "Delete components from managed package" enabled for your dev org for the time being to remove the permission set. help.salesforce.com/… – A-d Sep 20 '14 at 4:23
  • Don't use winter'15. Until it is on production – Ashwani Sep 20 '14 at 11:50
  • Thanks. Unfortunately, this problem is happening with both Summer '14 and Winter '15 pre-release orgs. EE, sandbox and DE. – ArtieBrosius Sep 20 '14 at 19:15
  • Also, I did ask for the "delete components from managed package" option enabled...but permission sets can't be deleted! That's frustrating for sure. – ArtieBrosius Sep 20 '14 at 19:16
  • Nasty - did you sort this out? – Caspar Harmer Apr 30 '15 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.