I am receiving this error while deploying Reports through ANT.

Type: Report, Error Msg: required field is missing: sourceValues

After investigation I found that the below 'backets' tag don't have tag 'sourceValues'.

enter image description here

However the thing is that I have just got these report files by ANT retrieve command from the same ORG. and Have not modified any file.

Is it related to version issue ? or something else ?

I am using ANT version: 1.9.3 package.xml version: 30.0

  • ,You are missing field named Sourcevalues in your destination instance .Is your orgs in sync with fields ? Sep 17, 2014 at 3:00
  • Its all being done in same ORG. Different ORGs not involved. Sep 17, 2014 at 3:26

2 Answers 2


Try replacing the following:



Do this for all <values> tags in the bucket fields that don't have the <sourceValues> tag. This worked for me and I was able to deploy using Ant.

I don't know why this happened but I just wanted to let you know what worked for me. Hope this helps you.

  • This is not the exact answer as I wanted to find out why that tag is missing when retrieved by ANT. However Marking this as 'answer' since its provide the way to move-on. Oct 12, 2014 at 3:37

This help article explains that this error occurs when you have a bucketed field that does not contain any values. The resolution is to either delete the bucketed field or modify it by adding some values to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.