2

While running encrypt.bat -e "C:\temp\key.txt"

I am getting the error below :

014-09-10 15:31:06,811 INFO [main] security.EncryptionUtil main (EncryptionUti l.java:289) - Invalid option format: ûe

3 Answers 3

2

I guess you copy pasted command encrypt.bat -e "C:\temp\key.txt" from some website.

It should be minus sign instead of dash, Can you try to type it and run it. You may find some helping steps here as well.

1

Change to encrypt -e "C:\temp\key.txt"

You may need to include the password and security token as you're not telling encrypt what to encrypt. e.g. encrypt -e myPasswordmySecurityToken "c:\temp\key.txt"

3
  • Tried but getting same error
    – nam
    Sep 10, 2014 at 11:04
  • I tried : encrypt.bat -e <Password+Securitytoken> "C:\temp\key.txt" , Im trying to create a encrypted password. help.salesforce.com/apex/…
    – nam
    Sep 10, 2014 at 11:12
  • 1
    don't use .bat in the command; just encrypt and it'll work. e.g. encrypt -e myPassword "c:\temp\key.txt" Sep 10, 2014 at 13:34
0

Install Java 32 Bit and try again.

It might be possible that your machine is 64-bit operating system and you have installed Java JDK 64-bit but Data loader requires 32-bit java to run these commands. Java should be installed in this location "C:\Program Files (x86)\Java".

Don't forget to change environment variable path also.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .