2

I have a community footer file that includes the jQuery library. When any standard page (i.e. edit/detail/list views) loads within the community the functionality is broken. For example, if I access a standard tab with a list view the list view will not load and gets stuck at "loading..". If any standard edit page is loaded the buttons (save, cancel) do not allow you to click on them.

I have narrowed down the problem to including jQuery (1.11) in the community footer file. I tried aliasing the jQuery variables with noconflict() but that does not make a difference. Even if I remove all of the jQuery code in the footer file it still breaks if the jQuery library is loaded.

Obviously there is a conflict with the standard SFDC jQuery being used. Any ideas on how to keep the jQuery library loaded in the footer and still get the standard pages to work correctly? jQuery is a requirement in order to load bootstrap which is also a requirement.

  • I have jQuery v1.10.2 loaded in a communities standard HTML header and I can use the Save and Edit buttons, as well as see list views, without issue. I do use noconflict() to cast jQuery to a variable. jQuery is loaded as the first script tag after html and head – greenstork Sep 4 '14 at 15:28
  • 1
    Yeah, I just tried reproducing this in a demo org with 1.11.1 loaded from google's cdn, and had no issue. How are you loading jquery? – Mark Masterson Sep 4 '14 at 15:57
  • Good to hear that it can work. I will have to experiment tonight to see if it is the jQuery UI version or some other combination. – Joe Sep 4 '14 at 17:10
  • <script src="ajax.googleapis.com/ajax/libs/jquery/1.11.0/…> <script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/jquery-ui.min.js"></script> – Joe Sep 4 '14 at 17:11
1

The issue was being caused from loading a different javascript library in the footer. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.